Issues accessing iAuditor via Internet Explorer 11
Incident Report for SafetyCulture AU
Resolved
Everything is back to normal! Let us know if you encounter any problems.
Posted 4 months ago. Aug 02, 2018 - 22:30 AEST
Monitoring
Our Engineering team have identified and resolved the issue impacting I.E 11.

Customers will now be able to access iAuditor via I.E 11 as normal. While services have been restored we will continue to monitor this issue closely
Posted 4 months ago. Aug 02, 2018 - 21:26 AEST
Update
We are continuing to investigate this issue.
Posted 4 months ago. Aug 02, 2018 - 19:48 AEST
Investigating
We are currently aware of an issue impacting access to iAuditor via Internet Explorer 11; customers may experience browser lockups and will be unable to access their Audits/Templates.

We are continuing to investigate the issue and will provide more information as it becomes available.
Posted 4 months ago. Aug 02, 2018 - 19:20 AEST
This incident affected: iAuditor Web Platform.